вторник, 5 октября 2010 г.

Configuring EIGRP

In the first years of computer networks, RIP was the king of routing protocols. But the limitation of 15 steps between networks was become a reason for developing other protocols. In this lesson we will view on configuration of another network protocol EIGRP.
The following things are the metrics:
-Bandwidth
-Delay
-Reliability
-Weight
According this parameters the summary metric is calculated.
EIGRP send periodically the update of route table to directly connected routers. Updates are send every 90 seconds. If there is not update after 270 seconds, the route will be marked as inactive. If there is no update after 630 seconds, the route will be deleted from the route table. Also you can change the updating timers using a "timers basic" command.

To enter in EIGRP configuration mode, you should enter "router eigrp" command {number of AS}. As is a list of networks with a common parameters of routing. You can access AS as an object. At this period of time you can have a problem in understanding AS, but then it will be clear.
Then using a "network {ip address} {EIGRP wild card bits}" enter a network, directly connected to router. Our router will send send this information to neighbour routers. EIGRP wild card bits = 255.255.255.255-{network mask}. Also using "passive-interface" command you can enter port, which will be blocked for sending updates.

Example of configuration:
Router(config)#router eigrp 200
Router(config-router)#network 192.168.1.0 0.0.0.255
Router(config-router)#network 192.168.2.0 0.0.0.3

Configuring RIP

RIP is one of the oldest routing protocols, but it is still used in small networks. In our days there are two versions of this protocol. The number of steps between routes from one network to another is the metric of this protocol(the maximum number is 15 for default). If the number is more that 15, the router will not deliver the package.
By default the routes are updated every 30 seconds. Updating of routing table are sent only to neighbour routers. Protocol RIP version 1 supports only network with standout masks, network classes A, B, C. RIP version 2 supports not only standard masks. Also authentication is supported by RIP version 2.
To enter in configuring RIP, you should enter "router rip" command. Then using command "version 1|2" you can choose the version of RIP.I suggest you to use RIP version 2, because it also includes RIP version 1 options. Then using "network" command you should provide the network, that connected to this router directly.

Main commands:
router rip - enter in configuration rip mode;
version(1|2) - protocol version;
network (ip address) - network address;
show ip route - show route table;
debug ip rip - enable debug mode for RIP.

Example of configuration:
Router(config)#router rip
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.1.0

Configuring static routes

The main function of router is to route the network traffic from one network segment to another one. Routers have a route database. According this database the traffic is routed by the network devices. In our days there are two ways of routing:
-Routing protocols(dynamic routing)
-Static routing

Routing protocols give the possibility to dynamically know the information about paths from one network to another. They are RIP, EIGRP, BGP, OSPF, IS-IS.
When you configure static routing, you manually write the path from one network to another. I am going to describe how to configure static routing on CISCO routers.

For configuring a path from one network to another you should write the following command:
ip route (destination ip network address) (mask) (interface/next hop ip address)
If there is no information about destination network (network address) in router, it will send all packets to a default gateway.

For configuring default gateway you should enter the following command:
ip route 0.0.0.0 0.0.0.0 (interface/ next hop ip address)

If you want to see the routing table in CISCO router, you should enter "show ip route" command.

You can find example of configuring static routing on CISCO device below:
Router>enable
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
Router(config)#ip route 192.168.3.0 255.255.255.0 fa0/0

Notification:
192.168.1.2 is a default gateway

Configuring DHCP

Each network device in the network must have an IP address. System administrators ussually give static IP addresses to routers, servers, printers and other network devices, which address must be static. Also you can assign static IP addresses to personal computers in the network, but if the users are always move and the number of users is huge, you should always change their addresses. To automate the process of delivering IP address there is DHCP network protocol, which is need to assign IP addresses automatically from a pool of available IP addresses. Now we will configure a DHCP server on CISCO router:
-excluding ip addresses, that will not be assigned automatically
-Configuring pool
-Configuring the parameters of this pool(default gateway, domain name)

Configuration:
R1>enable
R1#configure terminal
R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)#ip dhcp excluded-address 192.168.10.254
R1(config)#ip dhcp pool LAN-POOL-1
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#domain-name alexsplanet.com
R1(dhcp-config)#end

Notification:
Excluded addresses: 192.168.10.1 , 192.168.10.9
Pool name: LAN-POOL-1
Network: 192.168.10.0 255.255.255.0
Default gateway: 192.168.10.1
Domain: alexsplanet.com

Configuring interface

On the back panel of CiSCO devices you can find that every port has its own description (for example fa0/0, serial0/1). The commands below will help you assing ip address 192.168.1.1 with network mask 255.255.255.0 to a port fa0/0:

Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Configuring password

Connect to our router with a special CISCO cabel and a windows program HyperTerminal(Start-> Programs-> Accessories->Communications->HyperTerminal). On the desktop we can see a command line.
Then following the commands below we will configure a password for terminal and virtual lines (for console port and for telnet):

Router>enable             
Router#configure terminal     
Router(config)#service password-encryption 
Router(config)#line con 0               
Router(config-line)#password alexs   
Router(config-line)#login     
Router(config-line)#exit   
Router(config)#line vty 0 4              
Router(config-line)#password planet 
Router(config-line)#login    
Router(config-line)#exit
Router(config)#enable secret alexsplanet 

Notifications:
-password "alexs" is for console port
-password "planet" is for telnet connection
-password "alexsplanet" is for priveliage mode

Introduction to CISCO IOS

Cisco IOS - операционная система, на которой работают маршрутизаторы  CISCO. Для начала я опишу основные команды командной строки:
enable - вход в привилегированный режим.
show running-config - показывает текущую настройку роутера.
ping - проверяет связь с заданным сетевым устройством.
configure terminal - вход в режим конфигурирования.
show version - показывает версию операционной системы и различные системные ресурсы.
? - показывает все доступные команды в текущем режиме.
write mem - записать текущую конфигурацию в стартовую.
Cisco IOS is an operation system of Cisco routers. For the begining I will describe the main commands:
1) enable - enter in privelage mode
2) Show running-configuration - shows the current configuration of router
3) configure terminal - enter in configuration mode
4) show version - shows the version of operation system and other system resourses
5) ? - shows available commands in the current mode
6) write mem - save the current configuraion into the startup configuration.

Counter